Fuel Prices & Car Check Data

RESOLVED

This incident has been resolved.

Posted 16 hours, 56 minutes ago.

UPDATE

All fuel prices and car details are back live

Posted 17 hours, 44 minutes ago.

IDENTIFIED

The issue has been identified and a fix is being implemented.

Posted 17 hours, 50 minutes ago.

INVESTIGATING

We are currently investigating this issue.

Posted 19 hours, 51 minutes ago.

Component impacted: Mobile App